PHPUnit installation problem

Home Forums Learn ZF2 PHPUnit installation problem

This topic contains 2 replies, has 3 voices, and was last updated by  Slavey Karadzhov 3 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #254

    zimzum74@gmail.com
    Participant

    On page 99, after the modification of “composer.json” and running “php composer.phar install –dev” it says “This dev build of composer is outdated…”
    Then after updating it with “php composer.phar self-update” and running “php composer.phar install –dev” again it says “The lock file is not up to date with the latest changes in composer.json… Nothing to install or update”
    Any suggestions?

    #257

    Try using the self-update command:

    php composer.phar self-update

    and then again:
    php composer.phar install-dev

    Bye
    Giuseppe

    #262

    Slavey Karadzhov
    Participant

    Try Giuseppe’s advice. If it still does not work for you then first remove the composer.lock file and then run

    php composer.phar self-update
    php composer.phar install –dev

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.